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Copyright and License Information
This page can include Creative Commons or GNU Free Documentation, software and documentation; may include a summary with a link if licenses are available online.  Note: You should have the page you use here approved by your legal advisors.

Example: Copyright 2004 {Fill in organization name}. This software was developed in conjunction with the National Cancer Institute, and so to the extent government employees are co-authors, any rights in such works shall be subject to Title 17 of the United States Code,  section 105.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the disclaimer of Article 3, below. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

2. Affymetrix Pure Java run time library needs to be downloaded from  (http://www.affymetrix.com/support/developer/runtime_libraries/index.affx) after agreeing to the licensing terms from the Affymetrix. 

3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment:

"This product includes software developed by the {Fill in organization name} and the National Cancer Institute (NCI).”

If no such end-user documentation is to be included, this acknowledgment shall appear in the software itself, wherever such third-party acknowledgments normally appear.

4. The names "The National Cancer Institute," "NCI," and “{Fill in organization name}” must not be used to endorse or promote products derived from this software.

5. This license does not authorize the incorporation of this software into any proprietary programs. This license does not authorize the recipient to use any trademarks owned by either NCI or {Fill in organization name}.

6. THIS SOFTWARE IS PROVIDED "AS IS," AND ANY EXPRESSED OR IMPLIED WARRANTIES (INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE) ARE DISCLAIMED. IN NO EVENT SHALL THE NATIONAL CANCER INSTITUTE, SAIC, OR THEIR AFFILIATES BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

	Insert Names of Development Team(s) here

	Development
	User’s Guide
	Program Management

	Names of developers
	Names of technical writers and reviewers
	Names of program managers

	This is table format. Move from cell to cell by clicking the Tab key.
	To display grids, select the table (click 4-headed arrow at upper left of table). Click on table areas where you want grids to show.
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	
	
	

	1. Footnote contributing companies/ contractors/ divisions
	2. Company

	3. Department or division


	Contacts and Support

	Enter training contact
	name (email address)

	Enter customer support contact
	Web hyperlink
Telephone: 111-222-3456

Toll free: 888-234-1234


	LISTSERV Facilities Pertinent to software teams

	LISTSERV
	URL
	Name

	caBIO_Users 
	https://list.nih.gov/archives/cabio_users.html
	caBIO Users Discussion Forum

	caBIO_Developers 
	https://list.nih.gov/archives/cabio_developers.html
	caBIO Developers Discussion Forum

	caDSR_Users 
	https://list.nih.gov/archives/cadsr_users.html
	Cancer Data Standards Repository

	NCIEVS-L Listserv
	https://list.nih.gov/archives/ncievs-l.html
	NCI Vocabulary Services Information

	caArray_Users
	
	

	Add appropriate listservs and or websites here
	
	

	
	
	

	
	
	


Contents
iiIllustrations (optional)


1About This Guide


1Purpose


1Typical User


1Topics Covered


1Getting Started with {Software}


1Additional References


2Text Conventions Used


3Chapter 1
{Chapter Name}


3About (Heading 2)


3Using the (Heading 3)


5Chapter 2
Overview of {software}


5Software Overview


6Components of the Software


6Features and Functions of the Software


7Chapter 3
User Interface


9Chapter 4
Overview of User Types and Workflows


9User and/or Workflow


9Repeat for all user types


11Chapter 5
Error Messages/Indicators and Problem Resolutions


13Chapter 6
Glossary/Acronyms/ Abbreviations


15Appendix A
Glossary/Acronyms/ Abbreviations


17Appendix B
{Appendix Name}


19Appendix C
References


19Technical Manuals/Articles


19Scientific Publications


19caBIG Material


19caCORE Material


21Appendix D
Glossary


25Index




Illustrations (optional)
5Figure 1. Caption text goes here.


17Figure A.1. <Caption>


17Figure A.2. <Caption Indent>




If your manual images are mostly screen shots, a list may not be necessary. They don’t mean much outside of the text context.

About This Guide
This section introduces you to the {Title Property (File > Properties)}. Topics in this section include
· Purpose on this page
· Typical User on page 1
· Topics Covered on page 1
· Getting Started with {Software} on page 1
· Additional References on page 2
· Text Conventions Used on page 2
Purpose
Write a brief paragraph introducing the software for which this manual is written. Then tie that into the purpose of this chapter which is to describe the purpose, objectives, and brief directions for using this manual.
Typical User

This guide is designed for … who want to… 
Topics Covered

If you are new to {Application Name}, read this brief overview, which explains what you will find in each chapter and appendix.

·  macrobutton nomacro {Chapter number and name} 
·  macrobutton nomacro {Chapter number and name} 
·  macrobutton nomacro {Chapter number and name} 
·  macrobutton nomacro {Appendix number and name} 
·  macrobutton nomacro {Appendix number and name} 
·  macrobutton nomacro {Appendix number and name} 
Getting Started with {Software}

Bulleted list of sections in this guide to help user get started. You could include:

· Review Chapter 1 to learn about the manual structure

· Review Chapter 2 for a brief overview of the software

· Review Chapter X to learn system requirements 

· Refer to …. To learn about activating your license

· To start the software, refer to …..
Additional References

NOTE: If you have a long list of references, use an appendix instead of this section.
For more information about {Application Name}, see the following references:
·  macrobutton nomacro {Reference} 
·  macrobutton nomacro {Reference} 
·  macrobutton nomacro {Reference} 
Text Conventions Used

This section explains conventions used in this guide. The various typefaces represent interface components, keyboard shortcuts, toolbar buttons, dialog box options, and text that you type.
	Convention
	Description
	Example

	Bold
	Highlights names of option buttons, check boxes, drop-down menus, menu commands, command buttons, or icons.
	Click Search.

	URL
	Indicates a Web address.
	http://domain.com

	text in Small Caps
	Indicates a keyboard shortcut.
	Press Enter.

	text in Small Caps + text in Small Caps
	Indicates keys that are pressed simultaneously.
	Press Shift + Ctrl.

	Italics
	Highlights references to other documents, sections, figures, and tables.
	See Figure 4.5.

	Italic boldface monospace type
	Represents text that you type.
	In the New Subset text box, enter Proprietary Proteins.

	Note:
	Highlights information of particular importance.
	Note: This concept is used throughout this document.

	{  }
	Surrounds replaceable items.
	Replace {last name, first name} with the Principal Investigator’s name.


Chapter 1 {Chapter Name}
Introductory paragraph
Topics in this chapter include…

·  macrobutton nomacro {Topic} 
·  macrobutton nomacro {Topic} 
·  macrobutton nomacro {Topic} 
About (Heading 2)
Using the (Heading 3)
How to… (Heading 4)
By using the… (Heading 5)
To …, follow these steps:

1. Click the Open button.
The {name} window opens.

2. Select … from the drop-down list.

3. Follow these steps:

a. Do this.

Another window opens!

b. Do that.

c. Close the window.

4. Click OK.

d. Then do that.

e. Then do that.
Note:
To change the name of the manual in the left-facing page headers, select File > Properties. On the Summary tab, change the name of the book title. The header name will change correspondingly.

To insert a note like this one in the main body of the document, type the word Note, press Tab, then apply the Note Mainbody style. To insert a note in a procedure or bulleted list, do the same, but apply the Note Indent style.
Chapter 2 Overview of {software}

This chapter provides an overview of the software.

Topics in this chapter include: (bullet list and cross reference to sections in chapter).

· Software Overview on this page

· Component of software and functions on page xxx
· Etc.

Software Overview

Background of the software, if appropriate. Include pertinent website links, if appropriate. General description and scope of the system.

caBIG compatibility level

Images can be inserted where appropriate. Figure 1 is an example of an image copied and pasted in metafile format. Format the paragraph that holds the image using any of the following three styles: GraphicAnchorMain (for larger graphics that span the margins in the main body), GraphicAnchorIndent (for images small enough to align with the text margin or a list margin in the main body), and GraphicAnchorStep (to align graphics in procedures and bulleted lists).
When you press Enter after inserting an image, the Caption style is automatically applied. To insert a caption at the cursor, select Insert > Reference > Caption, and accept the defaults. Then type a period, a space, and your caption. 

If you need to indent your image and caption in a numbered or bulleted list, apply the Caption Indent style.
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Figure 1. Caption text goes here.
Note:
If you insert captions as described above, they will automatically update when you update the book.
Sections of this chapter could also include the following sections.
Components of the Software

Features and Functions of the Software
Chapter 3 User Interface
Description of user interface, viewer windows if appropriate, descriptions of graphical tools. This chapter can also include descriptions of global operations used consistently throughout the software. Examples of topics might be:

· Launching the interface

· Online help description

· The Application Workspace--This could include description of the viewer panes, expanding and collapsing folders, zoom functions, scrolling, layout options.

· Miscellaneous Interface Features--This could include selection techniques, edit functions, print functions, import and export features, etc.

Chapter 4 Overview of User Types and Workflows

This chapter could include the following topics:

User and/or Workflow

Task name

· Purpose of task

· Prerequisite information or other requirements

· Step by step instructions

· Related topics (include cross references, where appropriate)

Repeat for all tasks

Repeat for all user types

See Chapter 5 for an alternative to this outline.
Chapter 5 Error Messages/Indicators and Problem Resolutions

This chapter could include:

· Description and interpretation of error messages.

· How to resolve problems

· Troubleshooting section

· FAQs

A good format for FAQs:

	What is the Semantic Directory?
	The semantic layer (gov.nih.nci.semantic.*), is a self-contained package for semantic connector classes. The semantic connector is described in Insert Cross-reference.

	What is the Delegate/Service Locator?
	The Delegate layer, (gov.nih.nci.system.delegator), uses the resource locator (gov.nih.nci.system.servicelocator) to identify the data source where a query would be performed. For instance, if a query is for a Gene object for a criterion Taxon, this layer identifies the data source information as an internal RDBMS data base and uses the Object Relational Mapping (ORM) data access layer instance.


Arranging the space to put questions in a narrow column alongside their answers allows users to quickly find the questions that interest them. (These table borders do not print, but allow easy organization of material.)

Chapter 6 Glossary/Acronyms/ Abbreviations

You could divide this into separate chapters, depending on the number of entries here. You could also make this an appendix.

For an examples, see Appendix B.
Appendix A Glossary/Acronyms/ Abbreviations

Appendix B {Appendix Name}
Use the following appendix figure number format. Just copy and paste.
To include these in the Illustrations list, select each one, then press Alt + Shift + O (letter O). Select F as the table identifier.
Figure B.1. <Caption> TC "Figure A.1. <Caption>" \f F \l "1" 
Figure B.2. <Caption Indent> TC "Figure A.2. <Caption Indent>" \f F \l "1" 
Appendix C References
This appendix could include lists and hypertext links, where appropriate, to technical manuals, articles, scientific publications, etc. Examples are shown:

Technical Manuals/Articles

5.  XE "References:technical manuals, guides" 

 XE "References:scientific publications" National Cancer Institute. "caCORE 2.0 Technical Guide", ftp://ftp1.nci.nih.gov/pub/cacore/caCORE2.0_Tech_Guide.pdf 

6. Java Bean Specification: http://java.sun.com/products/javabeans/docs/spec.html
7. Foundations of Object-Relational Mapping: http://www.chimu.com/publications/objectRelational/
8. Object-Relational Mapping articles and products: http://www.service-architecture.com/object-relational-mapping/
9. Hibernate Reference Documentation: http://www.hibernate.org/hib_docs/reference/en/html/
10. Basic O/R Mapping: http://www.hibernate.org/hib_docs/reference/en/html/mapping.html
11. Java Programming: http://java.sun.com/learning/new2java/index.html
12. Javadoc tool: http://java.sun.com/j2se/javadoc/
13. JUnit: http://junit.sourceforge.net/
14. Extensible Markup Language: http://www.w3.org/TR/REC-xml/
15. XML Metadata Interchange: http://www.omg.org/technology/documents/formal/xmi.htm
Scientific Publications

caBIG Material

16. caBIG: http://cabig.nci.nih.gov/
17.  XE "References:caBIG materials" caBIG Compatibility Guidelines: http://cabig.nci.nih.gov/guidelines_documentation
 XE "References:caCORE material" caCORE Material

18. caCORE: http://ncicb.nci.nih.gov/core
19. caBIO: http://ncicb.nci.nih.gov/core/caBIO
20. caDSR: http://ncicb.nci.nih.gov/core/caDSR
21. EVS: http://ncicb.nci.nih.gov/core/EVS
22. CSM: http://ncicb.nci.nih.gov/core/CSM
Appendix D Glossary
 XE "Glossary" Following is an example list of terms and their definitions. You may use any of these you consider appropriate for your glossary.

	Term
	Definition

	API
	Application Programming Interface

	caArray
	cancer Array Informatics

	caBIG
	cancer Biomedical Informatics Grid

	caBIO
	Cancer Bioinformatics Infrastructure Objects

	caCORE
	cancer Common Ontologic Representation Environment

	caDSR
	Cancer Data Standards Repository

	caMOD
	Cancer Models Database 

	cardinality
	Cardinality describes the minimum and maximum number of associated objects within a set

	CDE
	Common Data Element

	CGAP
	Cancer Genome Anatomy Project

	CMAP
	Cancer Molecular Analysis Project

	CN
	Common Name 

	CS
	Classification Scheme

	CSI
	Classification Scheme Item

	CSM
	Common Security Module

	CTEP
	Cancer Therapy Evaluation Program

	CUI
	Concept Unique Identifier

	CVS
	Concurrent Versions System

	DAML
	DARPA Agent Markup Language

	DAO
	Data Access Objects

	DARPA
	Defense Advanced Research Projects Agency

	DAS
	Distributed Annotation System

	DL
	Description Logic

	EA
	Enterprise Architect

	EBI
	European Bioinformatics Institute

	EVS
	Enterprise Vocabulary Services

	GAI
	CGAP Genetic Annotation Initiative

	GEDP
	Gene Expression Data Portal

	HIPPA
	Health Insurance Portability and Accountability Act

	HLGT
	High Level Group Term

	HLT
	High Level Term

	HTTP
	Hypertext Transfer Protocol

	ISO
	International Organization for Standardization

	JAAS
	Java Authentication and Authorization Service

	JAR
	Java Archive

	Javadoc
	Tool for generating API documentation in HTML format from doc comments in source code (http://java.sun.com/j2se/javadoc/)

	JDBC
	Java Database Connectivity

	JET
	Java Emitter Templates

	JMI
	Java Metadata Interface

	JSP
	Java Server Pages

	JUnit
	A simple framework to write repeatable tests (http://junit.sourceforge.net/)

	LDAP
	Lightweight Directory Access Protocol 

	LLT
	Lowest Level Term

	LOINC
	Logical Observation Identifier Names and Codes

	MAGE
	MicroArray and Gene Expression

	MAGE-OM
	MicroArray Gene Expression - Object Model

	MedDRA
	Medical Dictionary for Regulatory Activities

	metadata
	Definitional data that provides information about or documentation of other data.

	MGED
	Microarray Gene Expression Data

	MMHCC
	Mouse Models of Human Cancers Consortium

	MO
	MGED Ontology

	multiplicity
	Multiplicity of an association end indicates the number of objects of the class on that end may be associated with a single object of the class on the other end

	NCI
	National Cancer Institute

	NCICB
	National Cancer Institute Center for Bioinformatics

	OIL
	Ontology Inference Layer

	OilEd
	Ontology editor allowing you to build ontologies using DAML+OIL

	OLLT
	Obsolete Lower Level Terms

	OMG
	Object Management Group

	ORM
	Object Relational Mapping

	PT
	Preferred Term

	RDBMS
	Relational Database Management System

	SDK
	Software Development Kit

	Semantic connector
	A development kit to link model elements to NCICB EVS concepts.

	SOC
	System Organ Class

	SPORE
	Specialized Programs of Research 

	SQL
	Structured Query Language

	SSC
	Special Search Categories

	UI
	User Interface

	UID
	User Identification

	UML
	Unified Modeling Language

	UMLS
	Unified Medical Language System

	UPT
	User Provisioning Tool

	URL
	Uniform Resource Locators

	VD
	Value Domain

	WAR
	Web Application Archive

	WSDL
	Web Services Description Language

	XMI
	XML Metadata Interchange (http://www.omg.org/technology/documents/formal/xmi.htm) - The main purpose of XMI is to enable easy interchange of metadata between modeling tools (based on the OMG-UML) and metadata repositories (OMG-MOF) in distributed heterogeneous environments


Index
It is very easy to generate an index and extremely helpful to the manual user. For suggestions for inserting index markers and generating an index, see the Style Guide at the following location:

https://cabig.nci.nih.gov/working_groups/Training_SLWG/Documents/Technical_Pubs_Style_Guide_021405_jbh.pdf
To preserve the following index formatting, do not delete the index. Just add, delete, and modify your own index entry fields, then right-click on the following index and select Update Field.
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Note to Document Author: With the exception of the document title and document headings, red and blue body text in this document is designed to help you describe processes and build standards and to help you build the deliverable from this template. Remove all such red and blue text before submitting any formal documentation, including both draft and/or final deliverables.


To see the prompt text in this template, turn on field shading: �Tools > Options > View > Field Shading - Always 


Be sure to include the software version and current document date.








